Information Exposure Affecting libgcrypt20 package, versions <1.6.3-2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.6% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIBGCRYPT20-11748065
  • published10 Aug 2025
  • disclosed29 Nov 2019

Introduced: 29 Nov 2019

CVE-2014-3591  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Debian:14 libgcrypt20 to version 1.6.3-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgcrypt20 package and not the libgcrypt20 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Libgcrypt before 1.6.3 and GnuPG before 1.4.19 does not implement ciphertext blinding for Elgamal decryption, which allows physically proximate attackers to obtain the server's private key by determining factors using crafted ciphertext and the fluctuations in the electromagnetic field during multiplication.

CVSS Base Scores

version 3.1