Uncontrolled Recursion Affecting libjettison-java package, versions <1.5.4-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.01% (59th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIBJETTISONJAVA-11748035
  • published10 Aug 2025
  • disclosed22 Mar 2023

Introduced: 22 Mar 2023

CVE-2023-1436  (opens in a new tab)
CWE-674  (opens in a new tab)

How to fix?

Upgrade Debian:14 libjettison-java to version 1.5.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libjettison-java package and not the libjettison-java package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

An infinite recursion is triggered in Jettison when constructing a JSONArray from a Collection that contains a self-reference in one of its elements. This leads to a StackOverflowError exception being thrown.

CVSS Base Scores

version 3.1