Out-of-bounds Read Affecting libsass package, versions <3.6.3-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.63% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIBSASS-11748746
  • published10 Aug 2025
  • disclosed4 Jun 2018

Introduced: 4 Jun 2018

CVE-2018-11698  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Debian:14 libsass to version 3.6.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsass package and not the libsass package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::handle_error which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.