Resource Exhaustion Affecting libsass package, versions <3.5.4+20180621~c0a6cf3-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.8% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIBSASS-11749101
  • published10 Aug 2025
  • disclosed4 Dec 2018

Introduced: 4 Dec 2018

CVE-2018-19837  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Debian:14 libsass to version 3.5.4+20180621~c0a6cf3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsass package and not the libsass package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

In LibSass prior to 3.5.5, Sass::Eval::operator()(Sass::Binary_Expression*) inside eval.cpp allows attackers to cause a denial-of-service resulting from stack consumption via a crafted sass file, because of certain incorrect parsing of '%' as a modulo operator in parser.cpp.