Out-of-bounds Write Affecting libsdl2 package, versions <2.0.20+dfsg-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.06% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIBSDL2-11748983
  • published10 Aug 2025
  • disclosed1 Apr 2022

Introduced: 1 Apr 2022

CVE-2021-33657  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Debian:14 libsdl2 to version 2.0.20+dfsg-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsdl2 package and not the libsdl2 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

There is a heap overflow problem in video/SDL_pixels.c in SDL (Simple DirectMedia Layer) 2.x to 2.0.18 versions. By crafting a malicious .BMP file, an attacker can cause the application using this library to crash, denial of service or Code execution.

CVSS Base Scores

version 3.1