Integer Overflow or Wraparound Affecting libsdl2 package, versions <2.0.6+dfsg1-4


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.07% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIBSDL2-11749089
  • published10 Aug 2025
  • disclosed11 Oct 2017

Introduced: 11 Oct 2017

CVE-2017-2888  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Debian:14 libsdl2 to version 2.0.6+dfsg1-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsdl2 package and not the libsdl2 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

An exploitable integer overflow vulnerability exists when creating a new RGB Surface in SDL 2.0.5. A specially crafted file can cause an integer overflow resulting in too little memory being allocated which can lead to a buffer overflow and potential code execution. An attacker can provide a specially crafted image file to trigger this vulnerability.

CVSS Base Scores

version 3.1