Out-of-bounds Write Affecting libsdl2 package, versions <2.0.6+dfsg1-4


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.1% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIBSDL2-11749267
  • published10 Aug 2025
  • disclosed8 Feb 2019

Introduced: 8 Feb 2019

CVE-2019-7637  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Debian:14 libsdl2 to version 2.0.6+dfsg1-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsdl2 package and not the libsdl2 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

SDL (Simple DirectMedia Layer) through 1.2.15 and 2.x through 2.0.9 has a heap-based buffer overflow in SDL_FillRect in video/SDL_surface.c.

CVSS Base Scores

version 3.1