Out-of-Bounds Affecting libvorbisidec package, versions <1.0.2+svn16259-2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.84% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIBVORBISIDEC-11749807
  • published10 Aug 2025
  • disclosed21 Sept 2007

Introduced: 21 Sep 2007

CVE-2007-4066  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:14 libvorbisidec to version 1.0.2+svn16259-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libvorbisidec package and not the libvorbisidec package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Multiple buffer overflows in Xiph.Org libvorbis before 1.2.0 allow context-dependent attackers to cause a denial of service or have other unspecified impact via a crafted OGG file, aka trac Changesets 13162, 13168, 13169, 13170, 13172, 13211, and 13215, as demonstrated by an overflow in oggenc.exe related to the _psy_noiseguards_8 array.

CVSS Base Scores

version 3.1