Out-of-bounds Write Affecting libyang package, versions <0.16.105-2


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.64% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIBYANG-11749932
  • published10 Aug 2025
  • disclosed6 Dec 2019

Introduced: 6 Dec 2019

CVE-2019-19333  (opens in a new tab)
CWE-787  (opens in a new tab)
CWE-121  (opens in a new tab)

How to fix?

Upgrade Debian:14 libyang to version 0.16.105-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libyang package and not the libyang package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

In all versions of libyang before 1.0-r5, a stack-based buffer overflow was discovered in the way libyang parses YANG files with a leaf of type "bits". An application that uses libyang to parse untrusted YANG files may be vulnerable to this flaw, which would allow an attacker to cause a denial of service or possibly gain code execution.

CVSS Base Scores

version 3.1