Link Following Affecting lightdm package, versions <1.0.6-2


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.31% (22nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIGHTDM-11750069
  • published10 Aug 2025
  • disclosed6 Mar 2014

Introduced: 6 Mar 2014

CVE-2011-3153  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Debian:14 lightdm to version 1.0.6-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lightdm package and not the lightdm package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

dmrc.c in Light Display Manager (aka LightDM) before 1.1.1 allows local users to read arbitrary files via a symlink attack on ~/.dmrc.

CVSS Base Scores

version 3.1