CVE-2020-15945 Affecting lua5.4 package, versions <5.4.1-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.55% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LUA54-11760069
  • published10 Aug 2025
  • disclosed24 Jul 2020

Introduced: 24 Jul 2020

CVE-2020-15945  (opens in a new tab)

How to fix?

Upgrade Debian:14 lua5.4 to version 5.4.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lua5.4 package and not the lua5.4 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Lua 5.4.0 (fixed in 5.4.1) has a segmentation fault in changedline in ldebug.c (e.g., when called by luaG_traceexec) because it incorrectly expects that an oldpc value is always updated upon a return of the flow of control to a function.

CVSS Base Scores

version 3.1