Use After Free Affecting lua5.4 package, versions <5.4.4-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.99% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LUA54-11760280
  • published10 Aug 2025
  • disclosed14 Mar 2022

Introduced: 14 Mar 2022

CVE-2021-44964  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:14 lua5.4 to version 5.4.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lua5.4 package and not the lua5.4 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Use after free in garbage collector and finalizer of lgc.c in Lua interpreter 5.4.0~5.4.3 allows attackers to perform Sandbox Escape via a crafted script file.

CVSS Base Scores

version 3.1