Out-of-bounds Read Affecting lua5.4 package, versions <5.4.4-2


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.98% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LUA54-11760283
  • published10 Aug 2025
  • disclosed8 Apr 2022

Introduced: 8 Apr 2022

CVE-2022-28805  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Debian:14 lua5.4 to version 5.4.4-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lua5.4 package and not the lua5.4 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

singlevar in lparser.c in Lua from (including) 5.4.0 up to (excluding) 5.4.4 lacks a certain luaK_exp2anyregup call, leading to a heap-based buffer over-read that might affect a system that compiles untrusted Lua code.

CVSS Base Scores

version 3.1