Insufficiently Protected Credentials Affecting lynx package, versions <2.9.0dev.6-3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.94% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LYNX-11760052
  • published10 Aug 2025
  • disclosed7 Aug 2021

Introduced: 7 Aug 2021

CVE-2021-38165  (opens in a new tab)
CWE-522  (opens in a new tab)

How to fix?

Upgrade Debian:14 lynx to version 2.9.0dev.6-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lynx package and not the lynx package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Lynx through 2.8.9 mishandles the userinfo subcomponent of a URI, which allows remote attackers to discover cleartext credentials because they may appear in SNI data.

CVSS Base Scores

version 3.1