Use After Free Affecting lynx package, versions <2.8.9dev16-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.73% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LYNX-11760268
  • published10 Aug 2025
  • disclosed17 Nov 2017

Introduced: 17 Nov 2017

CVE-2017-1000211  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:14 lynx to version 2.8.9dev16-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lynx package and not the lynx package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Lynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in memory disclosure, because HTML_put_string() can append a chunk onto itself.