Incorrect Authorization Affecting mapserver package, versions <7.6.2-2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.51% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-MAPSERVER-11760275
  • published10 Aug 2025
  • disclosed6 May 2021

Introduced: 6 May 2021

CVE-2021-32062  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade Debian:14 mapserver to version 7.6.2-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mapserver package and not the mapserver package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

MapServer before 7.0.8, 7.1.x and 7.2.x before 7.2.3, 7.3.x and 7.4.x before 7.4.5, and 7.5.x and 7.6.x before 7.6.3 does not properly enforce the MS_MAP_NO_PATH and MS_MAP_PATTERN restrictions that are intended to control the locations from which a mapfile may be loaded (with MapServer CGI).

CVSS Base Scores

version 3.1