Improper Input Validation Affecting mitmproxy package, versions <3.0.4-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.35% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-MITMPROXY-13634610
  • published19 Oct 2025
  • disclosed22 Jul 2018

Introduced: 22 Jul 2018

CVE-2018-14505  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:14 mitmproxy to version 3.0.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mitmproxy package and not the mitmproxy package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

mitmweb in mitmproxy v4.0.3 allows DNS Rebinding attacks, related to tools/web/app.py.