CVE-2026-84970 Affecting mongo-cxx-driver package, versions <4.5.2-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.12% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-MONGOCXXDRIVER-19530511
  • published4 Sept 2026
  • disclosed3 Sept 2026

Introduced: 3 Sep 2026

CVE-2026-84970  (opens in a new tab)

How to fix?

Upgrade Debian:14 mongo-cxx-driver to version 4.5.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mongo-cxx-driver package and not the mongo-cxx-driver package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A numeric truncation weakness exists in the JSON parsing component of the MongoDB C++ Driver's BSON library. An actor who controls the text that an embedding application hands to the library's public JSON parsing interface, when that text is very large, can cause the library to read memory beyond the supplied buffer and return it to the caller, to silently accept only part of the input as a complete document, or to terminate the process. No MongoDB server, credentials, or non-default configuration is required; the effect is confined to the process that uses the library.

CVSS Base Scores

version 3.1