Improper Certificate Validation Affecting mono package, versions <3.2.8+dfsg-10


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.97% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-MONO-11761023
  • published10 Aug 2025
  • disclosed8 Jan 2018

Introduced: 8 Jan 2018

CVE-2015-2318  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade Debian:14 mono to version 3.2.8+dfsg-10 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mono package and not the mono package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

The TLS stack in Mono before 3.12.1 allows man-in-the-middle attackers to conduct message skipping attacks and consequently impersonate clients by leveraging missing handshake state validation, aka a "SMACK SKIP-TLS" issue.