Memory Leak Affecting mosquitto package, versions <2.0.17-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.31% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-MOSQUITTO-11760790
  • published10 Aug 2025
  • disclosed1 Sept 2023

Introduced: 1 Sep 2023

CVE-2023-28366  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Debian:14 mosquitto to version 2.0.17-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mosquitto package and not the mosquitto package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

The broker in Eclipse Mosquitto 1.3.2 through 2.x before 2.0.16 has a memory leak that can be abused remotely when a client sends many QoS 2 messages with duplicate message IDs, and fails to respond to PUBREC commands. This occurs because of mishandling of EAGAIN from the libc send function.

CVSS Base Scores

version 3.1