Memory Leak Affecting mosquitto package, versions <2.0.20-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.75% (55th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-MOSQUITTO-11760795
  • published10 Aug 2025
  • disclosed11 Oct 2024

Introduced: 11 Oct 2024

CVE-2024-8376  (opens in a new tab)
CWE-401  (opens in a new tab)
CWE-416  (opens in a new tab)
CWE-755  (opens in a new tab)

How to fix?

Upgrade Debian:14 mosquitto to version 2.0.20-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mosquitto package and not the mosquitto package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

In Eclipse Mosquitto up to version 2.0.18a, an attacker can achieve memory leaking, segmentation fault or heap-use-after-free by sending specific sequences of "CONNECT", "DISCONNECT", "SUBSCRIBE", "UNSUBSCRIBE" and "PUBLISH" packets.

CVSS Base Scores

version 3.1