CVE-2021-34432 Affecting mosquitto package, versions <2.0.8-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.25% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-MOSQUITTO-11760909
  • published10 Aug 2025
  • disclosed27 Jul 2021

Introduced: 27 Jul 2021

CVE-2021-34432  (opens in a new tab)

How to fix?

Upgrade Debian:14 mosquitto to version 2.0.8-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mosquitto package and not the mosquitto package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

In Eclipse Mosquitto versions 2.0.7 and earlier, the server will crash if the client tries to send a PUBLISH packet with topic length = 0.

CVSS Base Scores

version 3.1