Use After Free Affecting mruby package, versions <3.1.0-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.92% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-MRUBY-11761055
  • published10 Aug 2025
  • disclosed26 Mar 2022

Introduced: 26 Mar 2022

CVE-2022-1071  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:14 mruby to version 3.1.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mruby package and not the mruby package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

User after free in mrb_vm_exec in GitHub repository mruby/mruby prior to 3.2.

CVSS Base Scores

version 3.1