Out-of-Bounds Affecting mruby package, versions <4.0.0-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.18% (7th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-MRUBY-15247511
  • published7 Feb 2026
  • disclosed6 Feb 2026

Introduced: 6 Feb 2026

CVE-2026-1979  (opens in a new tab)
CWE-119  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:14 mruby to version 4.0.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mruby package and not the mruby package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A flaw has been found in mruby up to 3.4.0. This affects the function mrb_vm_exec of the file src/vm.c of the component JMPNOT-to-JMPIF Optimization. Executing a manipulation can lead to use after free. The attack needs to be launched locally. The exploit has been published and may be used. This patch is called e50f15c1c6e131fa7934355eb02b8173b13df415. It is advisable to implement a patch to correct this issue.

CVSS Base Scores

version 3.1