Improper Cross-boundary Removal of Sensitive Data Affecting node-eventsource package, versions <2.0.2+~1.1.8-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.86% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-NODEEVENTSOURCE-11761831
  • published10 Aug 2025
  • disclosed12 May 2022

Introduced: 12 May 2022

CVE-2022-1650  (opens in a new tab)
CWE-212  (opens in a new tab)

How to fix?

Upgrade Debian:14 node-eventsource to version 2.0.2+~1.1.8-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-eventsource package and not the node-eventsource package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Improper Removal of Sensitive Information Before Storage or Transfer in GitHub repository eventsource/eventsource prior to v2.0.2.

CVSS Base Scores

version 3.1