CVE-2021-33502 Affecting node-got package, versions <11.8.1+~cs53.13.17-3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.71% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-NODEGOT-11762158
  • published10 Aug 2025
  • disclosed24 May 2021

Introduced: 24 May 2021

CVE-2021-33502  (opens in a new tab)

How to fix?

Upgrade Debian:14 node-got to version 11.8.1+~cs53.13.17-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-got package and not the node-got package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

The normalize-url package before 4.5.1, 5.x before 5.3.1, and 6.x before 6.0.1 for Node.js has a ReDoS (regular expression denial of service) issue because it has exponential performance for data: URLs.

CVSS Base Scores

version 3.1