Resource Exhaustion Affecting node-ini package, versions <2.0.0-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.66% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-NODEINI-11762083
  • published10 Aug 2025
  • disclosed11 Dec 2020

Introduced: 11 Dec 2020

CVE-2020-7788  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Debian:14 node-ini to version 2.0.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-ini package and not the node-ini package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

This affects the package ini before 1.3.6. If an attacker submits a malicious INI file to an application that parses it with ini.parse, they will pollute the prototype on the application. This can be exploited further depending on the context.

CVSS Base Scores

version 3.1