Access of Resource Using Incompatible Type ('Type Confusion') Affecting node-set-value package, versions <3.0.1-3


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.21% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-NODESETVALUE-11762216
  • published10 Aug 2025
  • disclosed12 Sept 2021

Introduced: 12 Sep 2021

CVE-2021-23440  (opens in a new tab)
CWE-843  (opens in a new tab)

How to fix?

Upgrade Debian:14 node-set-value to version 3.0.1-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-set-value package and not the node-set-value package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

This affects the package set-value before <2.0.1, >=3.0.0 <4.0.1. A type confusion vulnerability can lead to a bypass of CVE-2019-10747 when the user-provided keys used in the path parameter are arrays.

CVSS Base Scores

version 3.1