Incorrect Regular Expression Affecting node-sshpk package, versions <1.13.1+dfsg-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.71% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-NODESSHPK-11762067
  • published10 Aug 2025
  • disclosed7 Jun 2018

Introduced: 7 Jun 2018

CVE-2018-3737  (opens in a new tab)
CWE-185  (opens in a new tab)
CWE-770  (opens in a new tab)

How to fix?

Upgrade Debian:14 node-sshpk to version 1.13.1+dfsg-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-sshpk package and not the node-sshpk package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

sshpk is vulnerable to ReDoS when parsing crafted invalid public keys.

CVSS Base Scores

version 3.1