Open Redirect Affecting node-url-parse package, versions <1.2.0-2


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.81% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-NODEURLPARSE-11762101
  • published10 Aug 2025
  • disclosed12 Aug 2018

Introduced: 12 Aug 2018

CVE-2018-3774  (opens in a new tab)
CWE-601  (opens in a new tab)
CWE-918  (opens in a new tab)
CWE-425  (opens in a new tab)

How to fix?

Upgrade Debian:14 node-url-parse to version 1.2.0-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-url-parse package and not the node-url-parse package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Incorrect parsing in url-parse <1.4.3 returns wrong hostname which leads to multiple vulnerabilities such as SSRF, Open Redirect, Bypass Authentication Protocol.