Uncaught Exception Affecting node-yaml package, versions <2.1.3-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.09% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-NODEYAML-11762196
  • published10 Aug 2025
  • disclosed24 Apr 2023

Introduced: 24 Apr 2023

CVE-2023-2251  (opens in a new tab)
CWE-248  (opens in a new tab)

How to fix?

Upgrade Debian:14 node-yaml to version 2.1.3-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-yaml package and not the node-yaml package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Uncaught Exception in GitHub repository eemeli/yaml prior to 2.0.0-5.

CVSS Base Scores

version 3.1