Out-of-Bounds Affecting ocaml package, versions <4.02.3-9


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
5.31% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-OCAML-11762726
  • published10 Aug 2025
  • disclosed13 Jun 2016

Introduced: 13 Jun 2016

CVE-2015-8869  (opens in a new tab)
CWE-119  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Debian:14 ocaml to version 4.02.3-9 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ocaml package and not the ocaml package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

OCaml before 4.03.0 does not properly handle sign extensions, which allows remote attackers to conduct buffer overflow attacks or obtain sensitive information as demonstrated by a long string to the String.copy function.

CVSS Base Scores

version 3.1