Out-of-bounds Write Affecting opencv package, versions <3.2.0+dfsg-6


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.99% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-OPENCV-11762795
  • published10 Aug 2025
  • disclosed7 Aug 2017

Introduced: 7 Aug 2017

CVE-2017-12603  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Debian:14 opencv to version 3.2.0+dfsg-6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opencv package and not the opencv package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

OpenCV (Open Source Computer Vision Library) through 3.3 has an invalid write in the cv::RLByteStream::getBytes function in modules/imgcodecs/src/bitstrm.cpp when reading an image file by using cv::imread, as demonstrated by the 2-opencv-heapoverflow-fseek test case.

CVSS Base Scores

version 3.1