Out-of-bounds Read Affecting opencv package, versions <4.1.2+dfsg-3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.76% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-OPENCV-11763023
  • published10 Aug 2025
  • disclosed6 Dec 2019

Introduced: 6 Dec 2019

CVE-2019-19624  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Debian:14 opencv to version 4.1.2+dfsg-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opencv package and not the opencv package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

An out-of-bounds read was discovered in OpenCV before 4.1.1. Specifically, variable coarsest_scale is assumed to be greater than or equal to finest_scale within the calc()/ocl_calc() functions in dis_flow.cpp. However, this is not true when dealing with small images, leading to an out-of-bounds read of the heap-allocated arrays Ux and Uy.

CVSS Base Scores

version 3.1