Arbitrary Code Injection Affecting owncloud-client package, versions <2.11.0.8354+dfsg-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.75% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-OWNCLOUDCLIENT-11763851
  • published10 Aug 2025
  • disclosed15 Jan 2022

Introduced: 15 Jan 2022

CVE-2021-44537  (opens in a new tab)
CWE-74  (opens in a new tab)

How to fix?

Upgrade Debian:14 owncloud-client to version 2.11.0.8354+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream owncloud-client package and not the owncloud-client package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

ownCloud owncloud/client before 2.9.2 allows Resource Injection by a server into the desktop client via a URL, leading to remote code execution.

CVSS Base Scores

version 3.1