Integer Overflow or Wraparound Affecting p11-kit package, versions <0.23.22-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.47% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-P11KIT-11763852
  • published10 Aug 2025
  • disclosed16 Dec 2020

Introduced: 16 Dec 2020

CVE-2020-29361  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Debian:14 p11-kit to version 0.23.22-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream p11-kit package and not the p11-kit package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

An issue was discovered in p11-kit 0.21.1 through 0.23.21. Multiple integer overflows have been discovered in the array allocations in the p11-kit library and the p11-kit list command, where overflow checks are missing before calling realloc or calloc.

CVSS Base Scores

version 3.1