Improper Authentication Affecting pacemaker package, versions <1.1.13-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.23% (15th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PACEMAKER-11763721
  • published10 Aug 2025
  • disclosed18 Oct 2021

Introduced: 18 Oct 2021

CVE-2010-2496  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Debian:14 pacemaker to version 1.1.13-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pacemaker package and not the pacemaker package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

stonith-ng in pacemaker and cluster-glue passed passwords as commandline parameters, making it possible for local attackers to gain access to passwords of the HA stack and potentially influence its operations. This is fixed in cluster-glue 1.0.6 and newer, and pacemaker 1.1.3 and newer.

CVSS Base Scores

version 3.1