Use After Free Affecting pacemaker package, versions <2.0.1-3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.9% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PACEMAKER-11763875
  • published10 Aug 2025
  • disclosed18 Apr 2019

Introduced: 18 Apr 2019

CVE-2019-3885  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:14 pacemaker to version 2.0.1-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pacemaker package and not the pacemaker package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A use-after-free flaw was found in pacemaker up to and including version 2.0.1 which could result in certain sensitive information to be leaked via the system logs.