Improper Access Control Affecting pacemaker package, versions <2.0.5~rc2-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.87% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PACEMAKER-11763965
  • published10 Aug 2025
  • disclosed24 Nov 2020

Introduced: 24 Nov 2020

CVE-2020-25654  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade Debian:14 pacemaker to version 2.0.5~rc2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pacemaker package and not the pacemaker package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

An ACL bypass flaw was found in pacemaker. An attacker having a local account on the cluster and in the haclient group could use IPC communication with various daemons directly to perform certain tasks that they would be prevented by ACLs from doing if they went through the configuration.

CVSS Base Scores

version 3.1