Improper Authorization Affecting pacemaker package, versions <1.1.15-3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.4% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PACEMAKER-11764004
  • published10 Aug 2025
  • disclosed10 Sept 2018

Introduced: 10 Sep 2018

CVE-2016-7035  (opens in a new tab)
CWE-285  (opens in a new tab)

How to fix?

Upgrade Debian:14 pacemaker to version 1.1.15-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pacemaker package and not the pacemaker package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

An authorization flaw was found in Pacemaker before 1.1.16, where it did not properly guard its IPC interface. An attacker with an unprivileged account on a Pacemaker node could use this flaw to, for example, force the Local Resource Manager daemon to execute a script as root and thereby gain root access on the machine.