Improper Authentication Affecting pacemaker package, versions <2.0.1-3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.38% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PACEMAKER-11764025
  • published10 Aug 2025
  • disclosed18 Apr 2019

Introduced: 18 Apr 2019

CVE-2018-16877  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Debian:14 pacemaker to version 2.0.1-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pacemaker package and not the pacemaker package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A flaw was found in the way pacemaker's client-server authentication was implemented in versions up to and including 2.0.0. A local attacker could use this flaw, and combine it with other IPC weaknesses, to achieve local privilege escalation.

CVSS Base Scores

version 3.1