Improper Input Validation Affecting php-gettext package, versions <1.0.12-0.1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
6.38% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PHPGETTEXT-21693914
  • published24 Oct 2026
  • disclosed4 Nov 2019

Introduced: 4 Nov 2019

CVE-2015-8980  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:14 php-gettext to version 1.0.12-0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-gettext package and not the php-gettext package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

The plural form formula in ngettext family of calls in php-gettext before 1.0.12 allows remote attackers to execute arbitrary code.

CVSS Base Scores

version 3.1