Arbitrary Code Injection Affecting php-gettext package, versions <1.0.12-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
19.66% (98th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PHPGETTEXT-21693915
  • published24 Oct 2026
  • disclosed7 Feb 2017

Introduced: 7 Feb 2017

CVE-2016-6175  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Debian:14 php-gettext to version 1.0.12-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-gettext package and not the php-gettext package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Eval injection vulnerability in php-gettext 1.0.12 and earlier allows remote attackers to execute arbitrary PHP code via a crafted plural forms header.