Cross-site Scripting (XSS) Affecting php-league-commonmark package, versions <2.8.2-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.25% (17th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PHPLEAGUECOMMONMARK-15788929
  • published27 Mar 2026
  • disclosed24 Mar 2026

Introduced: 24 Mar 2026

CVE-2026-33347  (opens in a new tab)
CWE-79  (opens in a new tab)
CWE-185  (opens in a new tab)
CWE-918  (opens in a new tab)

How to fix?

Upgrade Debian:14 php-league-commonmark to version 2.8.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-league-commonmark package and not the php-league-commonmark package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

league/commonmark is a PHP Markdown parser. From version 2.3.0 to before version 2.8.2, the DomainFilteringAdapter in the Embed extension is vulnerable to an allowlist bypass due to a missing hostname boundary assertion in the domain-matching regex. An attacker-controlled domain like youtube.com.evil passes the allowlist check when youtube.com is an allowed domain. This issue has been patched in version 2.8.2.

CVSS Base Scores

version 3.1