Deserialization of Untrusted Data Affecting php-pear package, versions <1:1.10.6+submodules+notgz-1.1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
19.13% (98th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PHPPEAR-11764299
  • published10 Aug 2025
  • disclosed28 Dec 2018

Introduced: 28 Dec 2018

CVE-2018-1000888  (opens in a new tab)
CWE-502  (opens in a new tab)

How to fix?

Upgrade Debian:14 php-pear to version 1:1.10.6+submodules+notgz-1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-pear package and not the php-pear package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

PEAR Archive_Tar version 1.4.3 and earlier contains a CWE-502, CWE-915 vulnerability in the Archive_Tar class. There are several file operations with $v_header[&#39;filename&#39;] as parameter (such as file_exists, is_file, is_dir, etc). When extract is called without a specific prefix path, we can trigger unserialization by crafting a tar file with phar://[path_to_malicious_phar_file] as path. Object injection can be used to trigger destruct in the loaded PHP classes, e.g. the Archive_Tar class itself. With Archive_Tar object injection, arbitrary file deletion can occur because @unlink($this-&gt;_temp_tarname) is called. If another class with useful gadget is loaded, it may possible to cause remote code execution that can result in files being deleted or possibly modified. This vulnerability appears to have been fixed in 1.4.4.