Directory Traversal Affecting pigz package, versions <2.3.1-2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.03% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PIGZ-11764726
  • published10 Aug 2025
  • disclosed21 Jan 2015

Introduced: 21 Jan 2015

CVE-2015-1191  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Debian:14 pigz to version 2.3.1-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pigz package and not the pigz package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Multiple directory traversal vulnerabilities in pigz 2.3.1 allow remote attackers to write to arbitrary files via a (1) full pathname or (2) .. (dot dot) in an archive.

CVSS Base Scores

version 3.1