Memory Leak Affecting privoxy package, versions <3.0.29-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.25% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PRIVOXY-11765268
  • published10 Aug 2025
  • disclosed25 Mar 2021

Introduced: 25 Mar 2021

CVE-2021-20215  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Debian:14 privoxy to version 3.0.29-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream privoxy package and not the privoxy package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A flaw was found in Privoxy in versions before 3.0.29. Memory leaks in the show-status CGI handler when memory allocations fail can lead to a system crash.

CVSS Base Scores

version 3.1