Cross-site Scripting (XSS) Affecting prometheus package, versions <2.7.1+ds-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.5% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PROMETHEUS-11765282
  • published10 Aug 2025
  • disclosed26 Mar 2019

Introduced: 26 Mar 2019

CVE-2019-3826  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:14 prometheus to version 2.7.1+ds-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream prometheus package and not the prometheus package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A stored, DOM based, cross-site scripting (XSS) flaw was found in Prometheus before version 2.7.1. An attacker could exploit this by convincing an authenticated user to visit a crafted URL on a Prometheus server, allowing for the execution and persistent storage of arbitrary scripts.