Inadequate Encryption Strength Affecting pycryptodome package, versions <3.4.11-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.03% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PYCRYPTODOME-11765501
  • published10 Aug 2025
  • disclosed3 Feb 2018

Introduced: 3 Feb 2018

CVE-2018-6594  (opens in a new tab)
CWE-326  (opens in a new tab)

How to fix?

Upgrade Debian:14 pycryptodome to version 3.4.11-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pycryptodome package and not the pycryptodome package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

lib/Crypto/PublicKey/ElGamal.py in PyCrypto through 2.6.1 generates weak ElGamal key parameters, which allows attackers to obtain sensitive information by reading ciphertext data (i.e., it does not have semantic security in face of a ciphertext-only attack). The Decisional Diffie-Hellman (DDH) assumption does not hold for PyCrypto's ElGamal implementation.