CVE-2023-37463 Affecting python-cmarkgfm package, versions <2024.11.20-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.7% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PYTHONCMARKGFM-11765518
  • published10 Aug 2025
  • disclosed13 Jul 2023

Introduced: 13 Jul 2023

CVE-2023-37463  (opens in a new tab)

How to fix?

Upgrade Debian:14 python-cmarkgfm to version 2024.11.20-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-cmarkgfm package and not the python-cmarkgfm package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

cmark-gfm is an extended version of the C reference implementation of CommonMark, a rationalized version of Markdown syntax with a spec. Three polynomial time complexity issues in cmark-gfm may lead to unbounded resource exhaustion and subsequent denial of service. These vulnerabilities have been patched in 0.29.0.gfm.12.

CVSS Base Scores

version 3.1